Março 3, 2016 Shell

Instalando o ntPHPselector

Olá Pessoal, Pode acontecer de uma aplicação presente em seu VPS necessitar de uma versão do PHP diferente da atual. Tendo isso em vista eram apresentadas duas soluções: A primeira seria você atualizar a versão do PHP de forma global em seu VPS, porém, antes seria necessário montar um ambiente de testes local, para assim verificar se as […]

Olá Pessoal,

Pode acontecer de uma aplicação presente em seu VPS necessitar de uma versão do PHP diferente da atual. Tendo isso em vista eram apresentadas duas soluções: A primeira seria você atualizar a versão do PHP de forma global em seu VPS, porém, antes seria necessário montar um ambiente de testes local, para assim verificar se as aplicações são compatíveis com a nova versão do PHP escolhida. A segunda alternativa seria migrar para um de nossos servidores dedicados, onde nele iriam ser instalados o Cloudlinux + PHP Selector. Com isso cada conta cPanel poderia ter uma versão do PHP diferente da que está instalada de forma global no servidor.

O presente artigo vem apresentar uma terceira alternativa para esse tipo de solicitação, que seria a instalação do ntPHPselector.  A aplicação em questão é um plugin desenvolvido pela Nixtree, onde permite que o usuário selecione uma versão do PHP diferente para cada diretório de uma determinada conta cPanel.

Para a instalação do ntPHPselector, siga as etapas descritas abaixo:

1-  Logado em sua VPS via SSH acesse o seguinte diretório:

cd /usr/local/src

2- Realize o download do arquivo ntphpselector_manage.sh via wget:

wget -N https://nixtree.com/download/free/ntphpselector_manage.sh

3- Execute a instalação:

sh ntphpselector_manage.sh install

Caso você não queira mais utilizar a ferramenta, basta executar os seguintes comandos para sua remoção:

cd /usr/local/src
sh ntphpselector_manage.sh uninstall

OBSERVAÇÕES: 

1- Todos os procedimentos ( instalação e remoção) da aplicação são realizados via SSH.

2- A HostDime Brasil não se responsabiliza pelo bom funcionamento da aplicação, nem por instabilidades ou mal funcionamento na VPS, decorrente de sua instalação e utilização. Lembramos que a instalação, desinstalação ou qualquer tipo de procedimento efetuado junto à aplicações de terceiros é de responsabilidade do contratante.

3- A solução apresentada nesse presente artigo é apenas uma alternativa que pode ser adotada.

3-  Caso você não sinta segurança na realização do procedimento, entre em contato com um profissional da área.

4- O presente artigo é destinado apenas aos clientes da HostDime Brasil que possuem planos de VPS contratados.

Em caso de dúvidas ou solicitações, entre em contato através de um dos nossos canais de atendimento!

Deixe um comentário